Ridgecrest Baptist Church - Website Under Maintenance – Incident details

Website Under Maintenance

Identified
Major outage
Started 15 days ago

Affected

Ridgecrest Website

Major outage from 10:34 PM to 5:15 PM, Under maintenance from 5:15 PM to 12:00 AM

Updates
  • Update
    UTC
    Update

    We have deployed a maintenance page. Subscribe to this page by clicking "Get Updates"

  • Update
    UTC
    Update

    We are continuing to work on a fix for this incident. A maintenance page will be up shortly

  • Identified
    UTC
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    UTC
    Investigating
    Ridgecrest Website is down at the moment. This incident was automatically created by Instatus monitoring.